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This Quick Start explains how to set up a sample project to use the 
Embedded Cross Trigger (ECT) configurator. The configurator sets up 

trigger signals among the StarCore, SmartDMA

 

™

 

 (SDMA), and ARM

 

®

 

 
cores. First, you learn to use the ECT with two cores. Then, you learn to 
use the ECT with three cores:

In this section, you create and save an ECT matrix. You use this matrix to 
define a trigger that stops the ARM core when the StarCore part enters 
debug mode.

 

1. Open sample StarCore project

 

a. Select 

 

Start > Programs > Freescale CodeWarrior > 
CodeWarrior for StarCore and SDMA V1.0 > CodeWarrior IDE

 

 
from Windows task bar— IDE starts; CodeWarrior main window 
appears

b. From CodeWarrior menu bar, select 

 

File > Open

 

 — 

 

Open

 

 dialog 
box appears

c. Use dialog box to find and open ECT example directory at this 
location, where 

 

CodeWarrior

 

 is path to your CodeWarrior 
installation:

 

CodeWarrior

 

\(CodeWarrior_Examples)\ECT_Examples\
StarCore

 

d. Select 

 

StarCore.mcp

 

 file

e. Click 

 

Open

 

 button — system opens project; project window 
appears, docked at left side of main window

 

Section A: Using the ECT with Two Cores
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2. Configure remote connection for StarCore project

 

NOTE

 

As an example, this Quick Start shows how to create a remote 
connection for MXC-05 hardware. If you have different 
hardware, use these steps as a guide to create an appropriate 

 

remote connection.

a. Select 

 

Edit > Preferences

 

 from CodeWarrior menu bar — 

 

IDE 
Preferences

 

 window appears

b. Select 

 

Remote Connections

 

 from 

 

IDE Preference Panels

 

 list 
on left side of window — panel appears in window

 

IDE Preferences Window — Remote Connections

 

Quick Start.fm  Page 2  Thursday, March 16, 2006  12:47 PM



 

3

 

c. Click 

 

Add

 

 button — 

 

New Connection

 

 dialog box appears

 

New Connection Dialog Box

 

d. In 

 

Name

 

 text box, enter 

 

MXC-05 StarCore RVI

 

e. Use 

 

Debugger

 

 list box to specify 

 

SC100 RVI

 

f. In 

 

Server IP Address

 

 text box, enter IP address of RVICE server

g. Check 

 

Enable ECT

 

 checkbox

h. Click 

 

OK

 

 button — IDE saves new remote-connection 
configuration; name of new remote connection appears in
panel list

i. Click 

 

OK

 

 button — IDE Preferences window closes

 

3. Configure remote debugging for StarCore project

 

a. Select 

 

Edit > StarCore Stationery Settings

 

 from CodeWarrior 
menu bar — Target settings window appears

b. Select 

 

Remote Debugging

 

 from 

 

Target Settings Panels

 

 list on 
left side of window — panel appears in window
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Target Settings Window — Remote Debugging

 

c. Use 

 

Connection

 

 list box to specify remote connection that you 
created in step 2.

 

4. Configure remote-debugging options for project

 

a. Select 

 

Remote Debug Options

 

 from 

 

Target Settings Panels

 

 list 
on left side of window — panel appears in window

 

Target Settings Window — Remote Debug Options
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b. Check 

 

Use Memory Configuration File

 

 checkbox

c. Click 

 

Browse

 

 button — 

 

Choose the Debugger Memory 
Configuration File

 

 dialog box appears

d. Use dialog box to navigate to

 

CodeWarrior

 

\StarCore_Support\Initialization_Files\
MemoryConfigFiles

 

where 

 

CodeWarrior

 

 is path to your CodeWarrior installation

e. Use dialog box to select appropriate memory-configuration file for 
your hardware:

–

 

i.300-30_Memory_Example.mem

 

–

 

MXC_05_ect_enabled.mem

 

–

 

MXC275-30_Memory_Example_ect_enabled.mem

 

f. Use 

 

Path Type

 

 list box to specify 

 

Compiler Relative

 

g. Click 

 

Open

 

 button — path to selected memory-configuration file 
now appears to left of 

 

Browse

 

 button

 

5. Configure SC100 debugger target for project

 

a. Select 

 

SC100 Debugger Target

 

 from 

 

Target Settings Panels

 

 
list on left side of window — panel appears in window

 

Target Settings Window — SC100 Debugger Target
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b. Use 

 

Target

 

 list box to specify appropriate target for your 
hardware

c. Check 

 

Use Initialization File

 

 checkbox

d. Click 

 

Choose

 

 button — 

 

Choose the StarCore Register Init File

 

 
dialog box appears

e. Use dialog box to navigate to

 

CodeWarrior

 

\StarCore_Support\Initialization_Files\
RegisterConfigFiles

 

where 

 

CodeWarrior

 

 is path to your CodeWarrior installation

f. Use dialog box to select appropriate register-initialization file for 
your hardware:

–

 

i.300-30\i.300-30_Initialization_ect_
   enabled.cfg

 

–

 

MXC_05\MXC_05_Initialization_ddr16_
   ect_enabled.cfg

 

–

 

MXC275-30\MXC275-30_Initialization_ect_
   enabled.cfg

 

g. Use 

 

Path Type

 

 list box to specify 

 

Compiler Relative

 

h. Click 

 

Open

 

 button — path to selected initialization file now 
appears to left of 

 

Choose

 

 button

i. Click 

 

OK

 

 button — IDE saves changes; Target Settings window 
closes

 

6. Configure RealView

 

®

 

 Debugger

 

a. Select 

 

Start > Programs > ARM > RealView Developer Suite 
v

 

x

 

.

 

x

 

 > RealView Debugger v

 

x

 

.

 

x

 

 from Windows task bar (where 

 

x

 

.

 

x

 

 represents version number) – RealView Debugger Code 
window appears

b. Select 

 

Target > Connection Properties

 

 from RealView 
Debugger main menu bar – 

 

Connection Properties

 

 window 
appears
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Connection Properties Window

 

c. On left side of Connection Properties window, select 

 

CONNECTION=RealView ICE > Advanced Information > 
Default > ARM_config

 

d. On right side of Connection Properties window, click arrow button 
in 

 

Value

 

 column—debugger sets 

 

Vector catch

 

 to False

e. Select 

 

File > Close

 

—Connection Properties window closes

 

7. Connect to target hardware

 

a. From RealView Debugger main menu bar, select 

 

Target > 
Connect to Target

 

 —debugger connects to target hardware; 

 

Connection Control

 

 window appears

 

Connection Control Window
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b. On left side of Connection Control window, select 

 

ARM-ARM-NW 
> RealView ICE

 

—list of remote connections appears

c. Check checkbox next to appropriate target connection

 

8. Build and debug StarCore project

 

a. Select 

 

Project > Make

 

 from CodeWarrior menu bar — IDE builds 
(compiles, assembles, and links) source code; IDE generates 
executable program

b. Select 

 

Project > Debug

 

 — debugging session starts; thread 
window appears

 

Thread Window
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9. Configure ECT

 

a. With thread window open, select 

 

Debug > ECT > Configure

 

 — 
ECT Configurator appears

 

ECT Configurator

 

b. In 

 

Source DSP

 

 group, use 

 

Signal

 

 list box to specify 
-->ipg_debug, check Channel Map 0 checkbox, and click Apply 
button

c. In Source ARM group, use Signal list box to specify 
ect_edbgrq-->, check Channel Map 0 checkbox, and click Apply 
button

d. Click Summary button to view summary of ECT signals that you 
mapped to channels
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ECT Summary

e. Click OK button — ECT Summary window closes

f. In ECT Configurator, click Save button — Save Settings file 
dialog box appears
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Save Settings File Dialog Box

g. Use dialog box to navigate to

CodeWarrior\(CodeWarrior_Examples)\ECT_Examples

where CodeWarrior is path to your CodeWarrior installation

h. In File name text box, enter ect_config

i. Use Save as type list box to specify ECT files (*.xml)

j. Click Save button — IDE saves current ECT configuration

NOTE In Section B, you will load this saved ECT configuration.

k. Close ECT Configurator window

10. Run StarCore project and ARM core

a. From CodeWarrior IDE menu bar, select Project > Run — IDE 
runs StarCore project; StarCore part runs

b. From RealView Debugger menu bar, select Debug > Run — 
ARM core runs

c. From CodeWarrior IDE menu bar, select Debug > Break — IDE 
halts execution of StarCore project and goes into debug mode; 
notice that ARM core also stops
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11. End CodeWarrior and RealView debugging session

a. From CodeWarrior menu bar, select Debug > Kill — debug 
session ends; thread window closes

b. Close CodeWarrior IDE’s console windows

a. From RealView debugger menu bar, select Target > Disconnect 
— RealView debugger disconnects from hardware

In this section, you load the ECT matrix that you saved from Section A and 
then modify it. You define a new channel mapping that stops both the ARM 
core and the SDMA core when the StarCore part enters debug mode.

NOTE You must complete Section A before you continue with 
this section.

1. Open sample SDMA project

a. From CodeWarrior menu bar, select File > Open — Open dialog 
box appears

b. Use dialog box to find and open SDMA example directory at this 
location, where CodeWarrior is path to your CodeWarrior 
installation:

CodeWarrior\(CodeWarrior_Examples)\ECT_Examples\
SDMA

c. Select SDMA.mcp file

d. Click Open button — system opens project; project window 
appears, docked at left side of main window

Section B: Using the ECT with Three Cores

Quick Start.fm  Page 12  Thursday, March 16, 2006  12:47 PM



13

2. Configure remote connection for SDMA project

NOTE As an example, this Quick Start shows how to create a remote 
connection for MXC-05 hardware. If you have different 
hardware, use these steps as a guide to create an appropriate 
remote connection.

a. Select Edit > Preferences from CodeWarrior menu bar — IDE 
Preferences window appears

b. Select Remote Connections from IDE Preference Panels list 
on left side of window — panel appears in window

c. Click Add button — New Connection dialog box appears

d. In Name text box, enter MXC-05 SDMA RVI

e. Use Debugger list box to specify SDMA RVI

f. In Server IP Address text box, enter IP address of RVICE server

g. Check Enable ECT checkbox

h. Click OK button — IDE saves new remote-connection 
configuration; name of new remote connection appears in
panel list

i. Click OK button — IDE Preferences window closes

3. Configure remote debugging for SDMA project

a. Select Edit > SDMA Stationery Settings from CodeWarrior 
menu bar — Target settings window appears

b. Select Remote Debugging from Target Settings Panels list on 
left side of window — panel appears in window

c. Use Connection list box to specify remote connection that you 
created in step 2.

d. Set JTAG Clock Speed to 2000

4. Configure SDMA target settings

a. Select SDMA Target Settings from Target Settings Panels list 
on left side of window — panel appears in window

NOTE Make sure to select SDMA Target Settings, not 
SDMA Target.
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Target Settings Window — SDMA Target Settings

b. Use Target list box to specify appropriate target for your 
hardware

c. Click OK button — IDE saves changes; Target settings window 
closes

5. Connect to target hardware

a. From RealView Debugger main menu bar, select Target > 
Connect to Target —debugger connects to target hardware; 
Connection Control window appears

b. On left side of Connection Control window, select ARM-ARM-NW 
> RealView ICE—list of remote connections appears

c. Check checkbox next to appropriate target connection

6. Build and debug StarCore project

a. Select Window > x StarCore.mcp, where x is a number — 
StarCore project window comes forward

b. Select Project > Make — IDE builds (compiles/assembles and 
links) executable program

c. Select Project > Debug — debug session starts; thread window 
appears
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7. Build and debug SDMA project

a. Select Window > x SDMA.mcp, where x is a number — SDMA 
project window comes forward

b. Select Project > Make — IDE builds (compiles/assembles and 
links) executable program

c. Select Project > Debug — debug session starts; thread window 
appears

8. Wake up SDMA core

NOTE This step ensures that the SDMA core is not in sleep mode. 
This way, the SDMA core will respond to ECT events.

a. From RealView Debugger main menu bar, select Tools > 
Include Commands from File — Select File to Include 
Commands from dialog box appears

b. Use dialog box to navigate to

CodeWarrior\(CodeWarrior_Examples)\ECT_Examples

where CodeWarrior is path to your CodeWarrior installation

c. Select wakeupSdma.inc file

d. Click Open button — SDMA wakeup script runs

e. From CodeWarrior menu bar, select Window > x sdma.eld, 
where x is a number — SDMA thread window comes forward; 
SDMA core is no longer in sleep mode

9. Configure ECT

a. From CodeWarrior menu bar, select Window > x project.eld, 
where x is a number — StarCore thread window comes forward

b. Select Debug > ECT > Configure — ECT Configurator appears

c. Click Clear All button — ECT Configurator deletes previous 
channel mappings

d. Click Load button — Load Settings file dialog box appears
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e. Use dialog box to navigate to

CodeWarrior\(CodeWarrior_Examples)\ECT_Examples

where CodeWarrior is path to your CodeWarrior installation

f. Select ect_config.xml file

g. Click Open button — ECT Configurator loads saved settings

h. Click Summary button of ECT Configurator — ECT Summary 
window appears; note that settings match those saved in step 9 
of Section A.

i. Click OK button — ECT Summary window closes

j. In Source SDMA group, use Signal list box to specify 
sdma_dreq_in-->, check Channel Map 0 checkbox, and click 
Apply button

NOTE In this step, you created one additional channel mapping for 
the ECT matrix. This additional mapping persists for the current 
debugging session only. To include the additional mapping in 
future debugging sessions, re-save the ect_config.xml file.

k. Close ECT Configurator window

10. Run StarCore, SDMA, and ARM cores

a. Select Window > x project.eld, where x is a number — StarCore 
thread window comes forward

b. Select Project > Run — IDE runs StarCore project; StarCore 
part runs

c. Select Window > x sdma.eld, where x is a number — SDMA 
thread window comes forward

d. Select View > Registers — Registers window appears
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Registers Window

e. Navigate to SDAM RVI > ECT (SDMA) > SDMA_CTIINTACK

f. Double-click Value corresponding to SDMA_CTIINTACK

g. Enter 0xff — SDMA_CTIINTACK register is manually set; 
SDMA interrupt is acknowledged

NOTE The visible value of SDMA_CTIINTACK does not change, but 
the register is still set, acknowledging the SDMA interrupt.

h. Close Registers window

i. Select Window > x sdma.eld, where x is a number — SDMA 
thread window comes forward

j. Select Project > Run — IDE runs SDMA project; SDMA core 
runs

k. From RealView debugger menu bar, select Debug > Run — 
ARM core runs

l. From CodeWarrior IDE, select Window > x project.eld, where x 
is a number — StarCore thread window comes forward

m. From CodeWarrior menu bar, select Debug > Break — IDE halts 
execution of StarCore project and goes into debug mode; notice 
that both SDMA core and ARM core also stop
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11. End CodeWarrior debugging session

a. From CodeWarrior menu bar, select Debug > Kill — debug 
session ends; thread window closes

b. Close CodeWarrior IDE’s console and project windows

c. Select File > Exit — CodeWarrior IDE closes

12. End RealView debugging session

a. From RealView debugger menu bar, select Target > Disconnect 
— RealView debugger disconnects from hardware

b. Select File > Exit — Exit dialog box appears

c. Click Yes button — RealView debugger closes

Congratulations!
You just used CodeWarrior software to run a simple StarCore 

and SDMA program that uses the ECT.
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